Data Processing Delays on Tiktok/Pinterest/Youtube

Incident Report for Mention

Resolved

Tiktok, Pinterest, and Youtube data is fetching again. Several hours of delay for the system to refresh is expected.
Posted Oct 13, 2025 - 14:48 CEST

Update

We are continuing to investigate this issue.
Posted Oct 13, 2025 - 08:19 CEST

Investigating

Our data processing infrastructure is running behind which is causing inaccuracies in the reporting tools. No data has been lost and the system should be caught up shortly.
Posted Oct 09, 2025 - 17:24 CEST
This incident affected: App.