X (Twitter) outage
Incident Report for
Mention
Resolved
The X API is reporting fewer errors. We are monitoring the situation.
Posted
May
09
,
2025
-
20:42
CEST
Identified
The X API is reporting a high rate error. This is could affect our mentions flow and some parts of the app. We are monitoring the incident.
Posted
May
09
,
2025
-
20:20
CEST
This incident affected: App.
×
Subscribe to Incident
Subscribe to updates for
X (Twitter) outage
via . You'll receive .