Review Page Monitoring Incident

Incident Report for Mention

Resolved

This incident has been resolved. New reviews will arrive in the Feed.
Posted Nov 04, 2025 - 15:02 CET

Investigating

Our review page monitoring is currently unavailable, and new reviews are not syncing to the Feed. We are working on resolving the incident.
Posted Nov 03, 2025 - 15:11 CET
This incident affected: App.