Server issues
Incident Report for Mention
Resolved
This incident has been resolved.
Posted Mar 30, 2019 - 18:24 CET
Update
We're experiencing server issues and are currently looking into this.
Posted Mar 30, 2019 - 18:20 CET
Investigating
We're experiencing server issues and are currently looking into this.
Posted Mar 30, 2019 - 18:20 CET