Data outage
Incident Report for Mention
Resolved
Our twitter data source is working again since 11th july 2AM
Posted Jul 11, 2024 - 09:15 CEST
Investigating
Our Twitter Data source is currently down since 10h42 (GMT+2) We are working on restoring the connection as soon as possible.
Posted Jul 09, 2024 - 16:35 CEST
This incident affected: App.